Low volume & distortion problem

post questions / problems regarding Cyrus kit here, or any other queries of a tech nature.
User avatar
Brigstow
Jr. Member
Jr. Member
Posts: 66
Joined: Sun Dec 06, 2015 10:56 am
Location: Bristol UK
Contact:

Low volume & distortion problem

Postby Brigstow » Wed Jul 10, 2019 7:47 pm

Hey everyone

Just started having problems with my Cyrus Streamer/Amp setup. The other day the volume suddenly decreased to a point were I could go to maximum and it was just at an OK level, not even loud. Also, the sound had a slight distortion to it, something you really had to listen for, but on tracks I knew well I could easily hear it was there.

I have unplugged the two X Powers and just used the Cyrus Stream X2 and the Cyrus 8 DAC QX and the problem is there, so it's not one of the amps.

I have the music stored on a NAS and if I stream music to another unit the sound is fine. I am using a Windows laptop with Jriver.

The first time I noticed it I had played a whole album, but this evening, it was there almost instantly.

Any help please :(
"it never gets easier, you just go faster"
- - - - - - - - - - - - - - - - - - - - - - - - - - - -
Hi-Fi: Stream Xv2 - 8 DAC Qx - X Powers (x2 mono) - Dali Ikon 5 MkII
Portable: Cowon Plenue 1 - Oppo PM-3
Conservatory: Revo Supersystem

User avatar
mickbald
Addicted
Addicted
Posts: 1219
Joined: Wed Aug 06, 2014 10:01 pm
Location: Shropshire

Re: Low volume & distortion problem

Postby mickbald » Wed Jul 10, 2019 8:25 pm

I would do a factory reset - how to do that will be in the manual If you cannot find it let me know the model number of the streamer and I'll look it up for you.