Not Cyrus but...

regarding Cyrus products and other hifi related threads
MiniCoupeman
Hero Member
Hero Member
Posts: 696
Joined: Tue Jul 16, 2013 8:36 am
Location: Sittingbourne

Not Cyrus but...

Postby MiniCoupeman » Tue Apr 18, 2017 5:05 pm

Had to turn off my Nord amp for two weeks. When I turned back on it sounded dreadful! Just as I remembered it 'out of the box'. Do Bel Canto' suffer the same? Is it something about Class D?

User avatar
hifinutt
Addicted
Addicted
Posts: 4322
Joined: Mon Apr 10, 2006 7:21 pm

Re: Not Cyrus but...

Postby hifinutt » Tue Apr 18, 2017 6:34 pm

no , I don`t remember that being the case .
modwright 36.5 dual mono
msb s200 power amp
bel canto 3.5vbs/vbs1 FM1 tuner
onkyo sacd /Marantz sacd, sigmas conditioning
proac studio 125, cabling
rfc /chord epic //Townshend /acoustic zen

Ianmac
Hero Member
Hero Member
Posts: 888
Joined: Wed Jul 18, 2007 8:17 am
Location: Ayrshire Scotland

Re: Not Cyrus but...

Postby Ianmac » Tue Apr 18, 2017 6:35 pm

I have 4 Hypex class d amps and never experienced what you describe.

Has the amp restored itself to normal SQ levels after a few hours running ?

MiniCoupeman
Hero Member
Hero Member
Posts: 696
Joined: Tue Jul 16, 2013 8:36 am
Location: Sittingbourne

Re: Not Cyrus but...

Postby MiniCoupeman » Wed Apr 19, 2017 2:26 pm

Left it on overnight -24 hours. Normal service has been resumed. Odd.

Ianmac
Hero Member
Hero Member
Posts: 888
Joined: Wed Jul 18, 2007 8:17 am
Location: Ayrshire Scotland

Re: Not Cyrus but...

Postby Ianmac » Wed Apr 19, 2017 9:55 pm

Sounds like the DC level through the input stage to the main amp is out of tolerance.
It should normalise after a few minutes of switch on.
I would raise this issue with the manufacturer

MiniCoupeman
Hero Member
Hero Member
Posts: 696
Joined: Tue Jul 16, 2013 8:36 am
Location: Sittingbourne

Re: Not Cyrus but...

Postby MiniCoupeman » Thu Apr 20, 2017 2:09 pm

Thanks